const regex = /\|"([^|]*[^"|]\|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|"([^|]*[^"|]\\|)', 'g')
const str = `||field2|"field3"|"field4|"field5"||"fie""ld6||field7|. the expected result would be ||field2|"field3"|field4|"field5"||fie""ld6||field7|`;
const subst = `|$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);