package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\|"([^|]*[^"|]\|)`)
var str = `||field2|"field3"|"field4|"field5"||"fie""ld6||field7|. the expected result would be ||field2|"field3"|field4|"field5"||fie""ld6||field7|`
var substitution = "|$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}