$re = '/\|"([^|]*[^"|]\|)/';
$str = '||field2|"field3"|"field4|"field5"||"fie""ld6||field7|. the expected result would be ||field2|"field3"|field4|"field5"||fie""ld6||field7|';
$subst = "|$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;