import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|\"([^|]*[^\"|]\\|)";
final String string = "||field2|\"field3\"|\"field4|\"field5\"||\"fie\"\"ld6||field7|. the expected result would be ||field2|\"field3\"|field4|\"field5\"||fie\"\"ld6||field7|";
final String subst = "|$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}