import Foundation
let pattern = #"\|"([^|]*[^"|]\|)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"||field2|"field3"|"field4|"field5"||"fie""ld6||field7|. the expected result would be ||field2|"field3"|field4|"field5"||fie""ld6||field7|"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)