$re = '/\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)/i';
$str = 'The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle
This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);