import re
regex = re.compile(r"\(\d{4}(?:[\sāā-]+(?:\d{4}|present))?\)", flags=re.IGNORECASE)
test_str = ("The Adventures of Sherlock Holmes (1891ā1892) (series), (1892) (novel), Arthur Conan Doyle\n"
"This is Agent (1857), the years were (1987-1868), which lasted from (1678- Present)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")