#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\G(?!\A)|\[begin])[^["]*(?:\[(?!end])[^["]*)*"([^"]*)""
Local $sString = "codigo cualquiera 1" & @CRLF & _
"" & @CRLF & _
"[begin]" & @CRLF & _
"" & @CRLF & _
" "hola" <--- match a este" & @CRLF & _
"" & @CRLF & _
" 123" & @CRLF & _
"" & @CRLF & _
" hola "hola" <-- math a este otro" & @CRLF & _
"" & @CRLF & _
""chau!"" & @CRLF & _
"" & @CRLF & _
"[end]" & @CRLF & _
"[otro]" & @CRLF & _
"" & @CRLF & _
" "hola" <--- a este no" & @CRLF & _
"" & @CRLF & _
"[otro]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")