$re = '/(?:\G(?!\A)|\[begin])[^["]*(?:\[(?!end])[^["]*)*"([^"]*)"/';
$str = 'codigo cualquiera 1
[begin]
"hola" <--- match a este
123
hola "hola" <-- math a este otro
"chau!"
[end]
[otro]
"hola" <--- a este no
[otro]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);