re = /(?:\G(?!\A)|\[begin])[^["]*(?:\[(?!end])[^["]*)*"([^"]*)"/
str = 'codigo cualquiera 1
[begin]
"hola" <--- match a este
123
hola "hola" <-- math a este otro
"chau!"
[end]
[otro]
"hola" <--- a este no
[otro]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end