using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\[begin])[^[""]*(?:\[(?!end])[^[""]*)*""([^""]*)""";
string input = @"codigo cualquiera 1
[begin]
""hola"" <--- match a este
123
hola ""hola"" <-- math a este otro
""chau!""
[end]
[otro]
""hola"" <--- a este no
[otro]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}