const regex = /(?:\G(?!\A)|\[begin])[^["]*(?:\[(?!end])[^["]*)*"([^"]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|\\[begin])[^["]*(?:\\[(?!end])[^["]*)*"([^"]*)"', 'g')
const str = `codigo cualquiera 1
[begin]
"hola" <--- match a este
123
hola "hola" <-- math a este otro
"chau!"
[end]
[otro]
"hola" <--- a este no
[otro]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}