import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|\\[begin])[^[\"]*(?:\\[(?!end])[^[\"]*)*\"([^\"]*)\"";
final String string = "codigo cualquiera 1\n"
+ "\n"
+ "[begin]\n"
+ "\n"
+ " \"hola\" <--- match a este\n"
+ "\n"
+ " 123\n"
+ "\n"
+ " hola \"hola\" <-- math a este otro\n\n"
+ "\"chau!\"\n"
+ "\n"
+ "[end]\n"
+ "[otro]\n"
+ "\n"
+ " \"hola\" <--- a este no\n"
+ "\n"
+ "[otro]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}