package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*[\p{L}\d '\/\\\-\.]+?)[,\s]+((?:\d+)\s*(?:[\p{L}\d\/]*(?:\s*[-+]\s*[\p{L}\d\-+\/]*)?))$`)
var str = `Berthelsdorfer Str.12
Weg 4
Straße 4 282a
Am Pumpelberg 5+6
Ettore-Bugatti-Str. 6-14
Ettore Bugatti Strasse 6-14
Ettore Bugatti Straße 6-14
Ettore-Bugatti Straße 6-14
Ettore-Bugatti-Str. 6+14
Ettore Bugatti Strasse 6+14
Ettore Bugatti Straße 6+14
Ettore-Bugatti Straße 6+14
Ettore-Bugatti-Str. 6b-14a
Ettore Bugatti Strasse 6b-14
Ettore Bugatti Straße 6a - 14x
Ettore-Bugatti Straße 6c-14A
Ettore-Bugatti-Str. 6b- 14a
Ettore Bugatti Strasse 6b -14
Ettore Bugatti Straße 6a - 14x
Ettore Bugatti Straße 6 - 14
Ettore-Bugatti Straße 6c + 14A
Straße des 17. Oktober 3-14
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}