import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d*[\\p{L}\\d '\\/\\\\\\-\\.]+?)[,\\s]+((?:\\d+)\\s*(?:[\\p{L}\\d\\/]*(?:\\s*[-+]\\s*[\\p{L}\\d\\-+\\/]*)?))$";
final String string = "Berthelsdorfer Str.12\n"
+ "Weg 4\n"
+ "Straße 4 282a\n"
+ "Am Pumpelberg 5+6\n"
+ "Ettore-Bugatti-Str. 6-14\n"
+ "Ettore Bugatti Strasse 6-14\n"
+ "Ettore Bugatti Straße 6-14\n"
+ "Ettore-Bugatti Straße 6-14\n\n"
+ "Ettore-Bugatti-Str. 6+14\n"
+ "Ettore Bugatti Strasse 6+14\n"
+ "Ettore Bugatti Straße 6+14\n"
+ "Ettore-Bugatti Straße 6+14\n\n"
+ "Ettore-Bugatti-Str. 6b-14a\n"
+ "Ettore Bugatti Strasse 6b-14\n"
+ "Ettore Bugatti Straße 6a - 14x\n"
+ "Ettore-Bugatti Straße 6c-14A\n\n"
+ "Ettore-Bugatti-Str. 6b- 14a\n"
+ "Ettore Bugatti Strasse 6b -14\n"
+ "Ettore Bugatti Straße 6a - 14x\n"
+ "Ettore Bugatti Straße 6 - 14\n"
+ "Ettore-Bugatti Straße 6c + 14A\n"
+ "Straße des 17. Oktober 3-14\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}