import Foundation
let pattern = #"^(\d*[\p{L}\d '\/\\\-\.]+?)[,\s]+((?:\d+)\s*(?:[\p{L}\d\/]*(?:\s*[-+]\s*[\p{L}\d\-+\/]*)?))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Berthelsdorfer Str.12
Weg 4
Straße 4 282a
Am Pumpelberg 5+6
Ettore-Bugatti-Str. 6-14
Ettore Bugatti Strasse 6-14
Ettore Bugatti Straße 6-14
Ettore-Bugatti Straße 6-14
Ettore-Bugatti-Str. 6+14
Ettore Bugatti Strasse 6+14
Ettore Bugatti Straße 6+14
Ettore-Bugatti Straße 6+14
Ettore-Bugatti-Str. 6b-14a
Ettore Bugatti Strasse 6b-14
Ettore Bugatti Straße 6a - 14x
Ettore-Bugatti Straße 6c-14A
Ettore-Bugatti-Str. 6b- 14a
Ettore Bugatti Strasse 6b -14
Ettore Bugatti Straße 6a - 14x
Ettore Bugatti Straße 6 - 14
Ettore-Bugatti Straße 6c + 14A
Straße des 17. Oktober 3-14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)