$re = '/^(\d*[\p{L}\d \'\/\\\\\-\.]+?)[,\s]+((?:\d+)\s*(?:[\p{L}\d\/]*(?:\s*[-+]\s*[\p{L}\d\-+\/]*)?))$/m';
$str = 'Berthelsdorfer Str.12
Weg 4
Straße 4 282a
Am Pumpelberg 5+6
Ettore-Bugatti-Str. 6-14
Ettore Bugatti Strasse 6-14
Ettore Bugatti Straße 6-14
Ettore-Bugatti Straße 6-14
Ettore-Bugatti-Str. 6+14
Ettore Bugatti Strasse 6+14
Ettore Bugatti Straße 6+14
Ettore-Bugatti Straße 6+14
Ettore-Bugatti-Str. 6b-14a
Ettore Bugatti Strasse 6b-14
Ettore Bugatti Straße 6a - 14x
Ettore-Bugatti Straße 6c-14A
Ettore-Bugatti-Str. 6b- 14a
Ettore Bugatti Strasse 6b -14
Ettore Bugatti Straße 6a - 14x
Ettore Bugatti Straße 6 - 14
Ettore-Bugatti Straße 6c + 14A
Straße des 17. Oktober 3-14
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);