const regex = /^(\d*[\p{L}\d '\/\\\-\.]+?)[,\s]+((?:\d+)\s*(?:[\p{L}\d\/]*(?:\s*[-+]\s*[\p{L}\d\-+\/]*)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*[\\p{L}\\d \'\\\/\\\\\\-\\.]+?)[,\\s]+((?:\\d+)\\s*(?:[\\p{L}\\d\\\/]*(?:\\s*[-+]\\s*[\\p{L}\\d\\-+\\\/]*)?))$', 'gm')
const str = `Berthelsdorfer Str.12
Weg 4
Straße 4 282a
Am Pumpelberg 5+6
Ettore-Bugatti-Str. 6-14
Ettore Bugatti Strasse 6-14
Ettore Bugatti Straße 6-14
Ettore-Bugatti Straße 6-14
Ettore-Bugatti-Str. 6+14
Ettore Bugatti Strasse 6+14
Ettore Bugatti Straße 6+14
Ettore-Bugatti Straße 6+14
Ettore-Bugatti-Str. 6b-14a
Ettore Bugatti Strasse 6b-14
Ettore Bugatti Straße 6a - 14x
Ettore-Bugatti Straße 6c-14A
Ettore-Bugatti-Str. 6b- 14a
Ettore Bugatti Strasse 6b -14
Ettore Bugatti Straße 6a - 14x
Ettore Bugatti Straße 6 - 14
Ettore-Bugatti Straße 6c + 14A
Straße des 17. Oktober 3-14
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}