# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d*[\p{L}\d '\/\\\-\.]+?)[,\s]+((?:\d+)\s*(?:[\p{L}\d\/]*(?:\s*[-+]\s*[\p{L}\d\-+\/]*)?))$"
test_str = ("Berthelsdorfer Str.12\n"
"Weg 4\n"
"Straße 4 282a\n"
"Am Pumpelberg 5+6\n"
"Ettore-Bugatti-Str. 6-14\n"
"Ettore Bugatti Strasse 6-14\n"
"Ettore Bugatti Straße 6-14\n"
"Ettore-Bugatti Straße 6-14\n\n"
"Ettore-Bugatti-Str. 6+14\n"
"Ettore Bugatti Strasse 6+14\n"
"Ettore Bugatti Straße 6+14\n"
"Ettore-Bugatti Straße 6+14\n\n"
"Ettore-Bugatti-Str. 6b-14a\n"
"Ettore Bugatti Strasse 6b-14\n"
"Ettore Bugatti Straße 6a - 14x\n"
"Ettore-Bugatti Straße 6c-14A\n\n"
"Ettore-Bugatti-Str. 6b- 14a\n"
"Ettore Bugatti Strasse 6b -14\n"
"Ettore Bugatti Straße 6a - 14x\n"
"Ettore Bugatti Straße 6 - 14\n"
"Ettore-Bugatti Straße 6c + 14A\n"
"Straße des 17. Oktober 3-14\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.