#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*[Rr]amp\(FinalValue:([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),RampTime:([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)"
Local $sString = "Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)" & @CRLF & _
"Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)" & @CRLF & _
"Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)" & @CRLF & _
"Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)" & @CRLF & _
"Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)" & @CRLF & _
"Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")