use strict;
my $str = 'Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)';
my $regex = qr/([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*[Rr]amp\(FinalValue:([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),RampTime:([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}