#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?"<>|\r\n]+\\?)*(?:[^\\\/:*?"<>|\r\n]+\\)*[^\\\/:*?"<>|\r\n]*$"
Local $sString = "C:\test\file.txt" & @CRLF & _
"C:\test\isthisafile_or_directory" & @CRLF & _
"..\..\bin\my_executable.exe" & @CRLF & _
"\tes!rtr" & @CRLF & _
"\\SERVER\myfolder\" & @CRLF & _
"\\SERVER\myfolder\my folder\" & @CRLF & _
"\\192.168.0.1\INVALID SHARE\" & @CRLF & _
"\\192.168.0.1\SHARE\my folder\test.exe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")