use strict;
my $str = 'C:\\test\\file.txt
C:\\test\\isthisafile_or_directory
..\\..\\bin\\my_executable.exe
\\tes!rtr
\\\\SERVER\\myfolder\\
\\\\SERVER\\myfolder\\my folder\\
\\\\192.168.0.1\\INVALID SHARE\\
\\\\192.168.0.1\\SHARE\\my folder\\test.exe';
my $regex = qr/^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?"<>|\r\n]+\\?)*(?:[^\\\/:*?"<>|\r\n]+\\)*[^\\\/:*?"<>|\r\n]*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}