const regex = /^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?"<>|\r\n]+\\?)*(?:[^\\\/:*?"<>|\r\n]+\\)*[^\\\/:*?"<>|\r\n]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[a-z]:|\\\\\\\\[a-z0-9_.$●-]+\\\\[a-z0-9_.$●-]+)\\\\|\\\\?[^\\\\\\\/:*?"<>|\\r\\n]+\\\\?)*(?:[^\\\\\\\/:*?"<>|\\r\\n]+\\\\)*[^\\\\\\\/:*?"<>|\\r\\n]*$', 'gmi')
const str = `C:\\test\\file.txt
C:\\test\\isthisafile_or_directory
..\\..\\bin\\my_executable.exe
\\tes!rtr
\\\\SERVER\\myfolder\\
\\\\SERVER\\myfolder\\my folder\\
\\\\192.168.0.1\\INVALID SHARE\\
\\\\192.168.0.1\\SHARE\\my folder\\test.exe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}