# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?\"<>|\r\n]+\\?)*(?:[^\\\/:*?\"<>|\r\n]+\\)*[^\\\/:*?\"<>|\r\n]*$"
test_str = ("C:\\test\\file.txt\n"
"C:\\test\\isthisafile_or_directory\n"
"..\\..\\bin\\my_executable.exe\n"
"\\tes!rtr\n"
"\\\\SERVER\\myfolder\\\n"
"\\\\SERVER\\myfolder\\my folder\\\n"
"\\\\192.168.0.1\\INVALID SHARE\\\n"
"\\\\192.168.0.1\\SHARE\\my folder\\test.exe")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.