package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?"<>|\r\n]+\\?)*(?:[^\\\/:*?"<>|\r\n]+\\)*[^\\\/:*?"<>|\r\n]*$`)
var str = `C:\test\file.txt
C:\test\isthisafile_or_directory
..\..\bin\my_executable.exe
\tes!rtr
\\SERVER\myfolder\
\\SERVER\myfolder\my folder\
\\192.168.0.1\INVALID SHARE\
\\192.168.0.1\SHARE\my folder\test.exe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}