using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[a-z]:|\\\\[a-z0-9_.$●-]+\\[a-z0-9_.$●-]+)\\|\\?[^\\\/:*?""<>|\r\n]+\\?)*(?:[^\\\/:*?""<>|\r\n]+\\)*[^\\\/:*?""<>|\r\n]*$";
string input = @"C:\test\file.txt
C:\test\isthisafile_or_directory
..\..\bin\my_executable.exe
\tes!rtr
\\SERVER\myfolder\
\\SERVER\myfolder\my folder\
\\192.168.0.1\INVALID SHARE\
\\192.168.0.1\SHARE\my folder\test.exe";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}