#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\<input.*\>)\n"
Local $sString = " <td class="examplelink">" & @CRLF & _
" <input name="chkexpert[]" type="checkbox" value="Java" checked="checked">" & @CRLF & _
" Java" & @CRLF & _
" <input name="chkexpert[]2" type="checkbox" value="PHP" checked="checked">" & @CRLF & _
" PHP" & @CRLF & _
" <input name="chkexpert[]2" type="checkbox" value="ASP" checked="checked">" & @CRLF & _
" ASP" & @CRLF & _
" <input type="checkbox" name="chkexpert[]2" value=".NET">" & @CRLF & _
" .NET" & @CRLF & _
" <input name="chkexpert[]2" type="checkbox" value="JavaScript">" & @CRLF & _
" Java Script</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")