import Foundation
let pattern = #"(?<=\<input.*\>)\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<td class="examplelink">
<input name="chkexpert[]" type="checkbox" value="Java" checked="checked">
Java
<input name="chkexpert[]2" type="checkbox" value="PHP" checked="checked">
PHP
<input name="chkexpert[]2" type="checkbox" value="ASP" checked="checked">
ASP
<input type="checkbox" name="chkexpert[]2" value=".NET">
.NET
<input name="chkexpert[]2" type="checkbox" value="JavaScript">
Java Script</td>
</tr>
<tr>
<td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)