re = /(?<=\<input.*\>)\n/m
str = ' <td class="examplelink">
<input name="chkexpert[]" type="checkbox" value="Java" checked="checked">
Java
<input name="chkexpert[]2" type="checkbox" value="PHP" checked="checked">
PHP
<input name="chkexpert[]2" type="checkbox" value="ASP" checked="checked">
ASP
<input type="checkbox" name="chkexpert[]2" value=".NET">
.NET
<input name="chkexpert[]2" type="checkbox" value="JavaScript">
Java Script</td>
</tr>
<tr>
<td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end