using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\<input.*\>)\n";
string input = @" <td class=""examplelink"">
<input name=""chkexpert[]"" type=""checkbox"" value=""Java"" checked=""checked"">
Java
<input name=""chkexpert[]2"" type=""checkbox"" value=""PHP"" checked=""checked"">
PHP
<input name=""chkexpert[]2"" type=""checkbox"" value=""ASP"" checked=""checked"">
ASP
<input type=""checkbox"" name=""chkexpert[]2"" value="".NET"">
.NET
<input name=""chkexpert[]2"" type=""checkbox"" value=""JavaScript"">
Java Script</td>
</tr>
<tr>
<td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}