use strict;
my $str = ' <td class="examplelink">
<input name="chkexpert[]" type="checkbox" value="Java" checked="checked">
Java
<input name="chkexpert[]2" type="checkbox" value="PHP" checked="checked">
PHP
<input name="chkexpert[]2" type="checkbox" value="ASP" checked="checked">
ASP
<input type="checkbox" name="chkexpert[]2" value=".NET">
.NET
<input name="chkexpert[]2" type="checkbox" value="JavaScript">
Java Script</td>
</tr>
<tr>
<td>';
my $regex = qr/(?<=\<input.*\>)\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}