using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)";
string input = @"Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}