// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d+)").unwrap();
let string = "Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}