package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+)`)
var str = `Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}