$re = '/\b(\d+)/m';
$str = 'Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);