const regex = /\b(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)', 'gm')
const str = `Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}