re = /\b(\d+)/m
str = 'Harry Potter (1997)
Of Mice and Men (1937)
Babe Ruth Story, The (1948) Drama 948) Babe Ruth Story'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end