#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[url\]https?:\/\/twitter\.com\/(?:\#!\/)?(\w+)\/status(es)?\/(\d+)(\?s=\d+)?\[\/url\]"
Local $sString = "[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://twitter.com/MacRumors/status/1255253753155989507?s=20" & @CRLF & _
"" & @CRLF & _
"twitter.com/ksldc" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")