use strict;
my $str = '[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]
[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]
https://twitter.com/MacRumors/status/1255253753155989507?s=20
twitter.com/ksldc
';
my $regex = qr/\[url\]https?:\/\/twitter\.com\/(?:\#!\/)?(\w+)\/status(es)?\/(\d+)(\?s=\d+)?\[\/url\]/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}