$re = '/\[url\]https?:\/\/twitter\.com\/(?:\#!\/)?(\w+)\/status(es)?\/(\d+)(\?s=\d+)?\[\/url\]/mi';
$str = '[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]
[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]
https://twitter.com/MacRumors/status/1255253753155989507?s=20
twitter.com/ksldc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);