import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[url\\]https?:\\/\\/twitter\\.com\\/(?:\\#!\\/)?(\\w+)\\/status(es)?\\/(\\d+)(\\?s=\\d+)?\\[\\/url\\]";
final String string = "[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]\n\n\n"
+ "[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]\n\n\n"
+ "https://twitter.com/MacRumors/status/1255253753155989507?s=20\n\n"
+ "twitter.com/ksldc\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}