re = /\[url\]https?:\/\/twitter\.com\/(?:\#!\/)?(\w+)\/status(es)?\/(\d+)(\?s=\d+)?\[\/url\]/mi
str = '[url]https://twitter.com/capitalweather/status/1255596050162860037[/url]
[url]https://twitter.com/capitalweather/status/1255596050162860037?s=12[/url]
https://twitter.com/MacRumors/status/1255253753155989507?s=20
twitter.com/ksldc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end