using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b";
string input = @"CAT-17
CAT-19h
CAT-20j";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}