package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b`)
var str = `CAT-17
CAT-19h
CAT-20j`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}