// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b").unwrap();
let string = "CAT-17
CAT-19h
CAT-20j";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}