$re = '/\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b/';
$str = 'CAT-17
CAT-19h
CAT-20j';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);