const regex = /\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:CAT-17([\\w]+)|CAT-19([\\w]+)|CAT-20([\\w]+))\\b', 'g')
const str = `CAT-17
CAT-19h
CAT-20j`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}