re = /\b(?:CAT-17([\w]+)|CAT-19([\w]+)|CAT-20([\w]+))\b/
str = 'CAT-17
CAT-19h
CAT-20j'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end