#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}$"
Local $sString = "# All POS codes should be 2 digits" & @CRLF & _
"# NOTE: Single digits should have a leading 0" & @CRLF & _
"# It's possible data loading might drop this! This regex would therefore fail" & @CRLF & _
"# This regex will also match codes that are currently unassigned" & @CRLF & _
"# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets" & @CRLF & _
"01" & @CRLF & _
"04" & @CRLF & _
"10" & @CRLF & _
"55" & @CRLF & _
"99" & @CRLF & _
"# Checks" & @CRLF & _
"0A" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"A0" & @CRLF & _
"--" & @CRLF & _
"990" & @CRLF & _
"010" & @CRLF & _
"**" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")